LIksDE prelazi na Kut

napisao dana jul 7, 2013 U Kratke vesti + LIksDe 2 komentara

LIksDE je GTK2-bazirano radno okruženje koji slovi za veoma lagano i samim tim pogodno, ako ne i preporučljivo, za računare sa skromnijim performansama. I same aplikacije koje dolaze uz ovo okruženje su takve da troše minimum resursa kojima raspolaže računar.

Obzirom da je razvoj GTK 2+ prestao, okruženja koja su se bazirala na ovom radnom okviru prelaze na GTK 3+, što je i očekivano. Međutim, programeri koji stoje iza LIksDE-a su doneli odluku da razvoj ovog okruženja nastave u Kut4 (Qt4) radnom okviru (stim što se najavljuje i prelazak na Kut5.1, kasnije). Shodno tome, naziv koji je trenutno prihvaćen je LIksDE-Kut (engl. lxde-Qt).

Na projektu se aktivno radi, a prema rečima ljudi koji stoje iza projekta – LIksDE-Kut više nije plan ili koncept već stvarni projekat koji postepeno ali sigurno dobija svoj oblik.

U vezi sa ovim, LIkspanel je portovan na Kut i postao je LIkspanel-Kut (lxpanel-qt). Takođe, i PCManFM upravnik fajlovima, i sada je PCManFM-Kut (PCManFM-qt). Program koji je korišćen za pregled slika, G-PikVju (engl. GPicView), je zamenjen novim – LIksImejdž-Kut (engl. LxImage-Qt) koji se, kako iz samog naziva proizilazi, zasniva na Kut radnom okviru. Naravno, ovde nije kraj…

Što se tiče samog prelaska na Kut, po rečima razvijača, to nije nimalo loš potez. Istina je da će sada utrošak resursa biti nešto veći, ali daleko od toga da LIksDE više neće biti lagano okruženje, tako da neke kritike koje se odnose na to nimalo ne stoje. Zašto? Zato što bi prelaskom na GTK 3+ taj utrošak bio veći, odnosno probližan, ako ne i isti, kao i u ovoj situaciji. A prelazak na GTK 3+ je neminovan. S druge strane, utrošak radne memorije zavisi i od konkretne distribucije. Na primer, LIksDE znatno manje troši resurse na Arču nego na Ubuntuu.

Razvoj ovog projekta se odvija u saradnji sa ljudima koji razvijaju Razor-Kut (engl. Razor-qt) radno okruženje. LIksDE komponente koje su portovane su zapravo razvijane imajući u vidu Razor-Kut. Trenutna podržana verzija Kut-a je 4. Verzija 5 će biti preskočena, tako da će sledeća podržana verzija biti Kut 5.1. Kut 4 i Kut 5 su kompatibilni u mnogim oblastima, tako da prelaz neće biti komplikovan. Međutim, to nije slučaj sa stvarima koje se oslanjaju na Iks11 (engl. X11). Kut 5 je uklonio mnoge API-e koji se odnose na Iks11, tako da trenutno ne postoji ekvivalent. Da bi se prešlo na Vejlend (engl. Wayland), to prvo treba da se reši. Na tome rade timovi koji razvijaju KDE i Gnom radna okruženja. Kut 5.1 će vratiti prethodno uklonjene API-e koji se odnose na Iks11, tako da će prelazak sa Kut 4 na Kut 5.1 biti bezbolan.

 

IZVOR: lxde blog